$re = '/(?<!, )so/m';
$str = 'So that
so big that
, so so';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);