import Foundation
let pattern = #"P(\d+([,\.]\d+)?Y)?(\d+([,\.]\d+)?M)?(\d+([,\.]\d+)?D)?(T(\d+([,\.]\d+)?H)?(\d+([,\.]\d+)?M)?(\d+([,\.]\d+)?S)?)?|P\d+([,\.]\d+?)W"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
P1Y
PT35M
P0.5Y
P4W
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)