import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([01]?\\d|2[0-3]):([0-5][0-9])";
final String string = "12:45am\n"
+ "9:59 AM\n"
+ "6:60am\n"
+ "15:00\n"
+ "90:45\n"
+ "12:45\n"
+ "2:00\n"
+ "five o'clock\n\n"
+ "[0-2]?\\d";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}