use strict;
my $str = '12:45am
9:59 AM
6:60am
15:00
90:45
12:45
2:00
five o\'clock
[0-2]?\\d';
my $regex = qr/^([01]?\d|2[0-3]):([0-5][0-9])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}