import Foundation
let pattern = #",[a-zA-Z ]+,1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1351,Adanac St,North,2,2015
1375,Adanac St,North,1,2015
305,Alexander St,North,1,2012
320,Alexander St,South,2,2014
429,Alexander St,North,2,2015
475,Alexander St,North,2,2012
611,Alexander St,North,3,2015
200,Alexander St,North,2,2012
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)