package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(')([^:,]+?)(')([^:,]+?)(')(:|,)`)
var str = `'statusid':'2000',
'country':'Hungary',
'pcode':'2000',
'city':'Budapest',
'street':'Route d'Arlon',
'houseno':'12',
'score':'100',
'gpslong':'6'09419',
'gpslat':'49'617081',
'a'a':'a',`
var substitution = "$1$2\\'$4$5$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}