$re = '/\b(váš|Váš|náš|Náš)\b/u';
$str = 'Náš počítač je ideální společník na cesty.náš.dsfsdf/efzs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);