// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[\s\S]*)(\{.*)").unwrap();
let string = "{Hello}, [123:456] (Test). This is stample data used to answer a
question {Hello2} [Ch.8 p. 87";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}