#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[^{])\-(?=[^{}]+}})"
Local $sString = "Hello {{first-name}}, how are you?" & @CRLF & _
"Hello {{first-name, last-name}}, how are you?" & @CRLF & _
"Hello {{-name, name-}} how are you?" & @CRLF & _
"Hello {{first}}-{{last}}, how are you?"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)