using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[^{])\-(?=[^{}]+}})";
string substitution = @"_";
string input = @"Hello {{first-name}}, how are you?
Hello {{first-name, last-name}}, how are you?
Hello {{-name, name-}} how are you?
Hello {{first}}-{{last}}, how are you?";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}