#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-z]+[.]+[a-zA-z]*[@]eil.co.in"
Local $sString = " "ABHAY KUMAR" <abhay.kumar@eil.co.in>, "JATINDER S DUGGAL" <js.duggal@eil.co.in>, "MAHESH EASWARAN" <mahesh.easwaran@eil.co.in>, "MAHESH GUPTA" <mahesh.gupta@eil.co.in>, "MUKESH KUMAR" <mukesh.kumar@eil.co.in>, "anand yadav" <anand.yadav@eil.co.in>, "SANJIT KUMAR KESHRI" <sanjit.keshri@eil.co.in>, "PINTU LAL" <pintu.lal@eil.co.in>, "SUSHANT CHANDRA SAXENA" <sushant.saxena@eil.co.in>, "VIKAS VIKAS" <vikask@eil.co.in>, "PRINCE PRINCE" <prince.gupta@eil.co.in>" & @CRLF & _
"Cc: "NALIN KUMAR" <kumar.nalin@eil.co.in>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")