use strict;
my $str = ' "ABHAY KUMAR" <abhay.kumar@eil.co.in>, "JATINDER S DUGGAL" <js.duggal@eil.co.in>, "MAHESH EASWARAN" <mahesh.easwaran@eil.co.in>, "MAHESH GUPTA" <mahesh.gupta@eil.co.in>, "MUKESH KUMAR" <mukesh.kumar@eil.co.in>, "anand yadav" <anand.yadav@eil.co.in>, "SANJIT KUMAR KESHRI" <sanjit.keshri@eil.co.in>, "PINTU LAL" <pintu.lal@eil.co.in>, "SUSHANT CHANDRA SAXENA" <sushant.saxena@eil.co.in>, "VIKAS VIKAS" <vikask@eil.co.in>, "PRINCE PRINCE" <prince.gupta@eil.co.in>
Cc: "NALIN KUMAR" <kumar.nalin@eil.co.in>';
my $regex = qr/[a-zA-z]+[.]+[a-zA-z]*[@]eil.co.in/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}