#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?=[a-z][^_]*_?[^_]+$)\w{4,}$"
Local $sString = "a88" & @CRLF & _
"hell_0" & @CRLF & _
"_und" & @CRLF & _
"u_nd" & @CRLF & _
"un_d" & @CRLF & _
"und_" & @CRLF & _
"u_n_" & @CRLF & _
"u__d" & @CRLF & _
"8_no" & @CRLF & _
"hell0_" & @CRLF & _
"helol_z" & @CRLF & _
"he_lo" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"it is made up of at least 4 characters" & @CRLF & _
"it can contain only word character, number, and underscore (max. one time)" & @CRLF & _
"it should start with a word character and it cannot end with an underscore."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")