use strict;
my $str = 'a88
hell_0
_und
u_nd
un_d
und_
u_n_
u__d
8_no
hell0_
helol_z
he_lo
it is made up of at least 4 characters
it can contain only word character, number, and underscore (max. one time)
it should start with a word character and it cannot end with an underscore.';
my $regex = qr/^(?=[a-z][^_]*_?[^_]+$)\w{4,}$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}