const regex = /(?<!\S)(?!\S*flowers\.com\.au)(\w+(?:\.[^\s,.#]+)+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)(?!\\S*flowers\\.com\\.au)(\\w+(?:\\.[^\\s,.#]+)+)', 'gm')
const str = `this is example.com.au and this is exampleflowers.com.au and of course another anotherexample.com.au/terms.html, url. Oh no exampleflowers.com.au is in this sentence again.`;
const subst = `<a href="$1">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);