import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?)\\s*\\b(\\d{5,7}\\b.*)";
final String string = "1338516 -...pair - 5pk 1409093 -...re Wax 3Pk\n"
+ "1409085 -...dtnr - 5pk 1415090 -...accessories\n"
+ "490663 - 3 pack 1490739 -...2 - 3 pack";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}