const regex = /(?!<a[^>]*?>)Java(?![a-z])(?![^<]*?<\/a>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!<a[^>]*?>)Java(?![a-z])(?![^<]*?<\\\/a>)', 'gm')
const str = `Java <li>Javascript</li> <a href="">Some Java here</a> more java`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}