$re = '/[0-9.]/m';
$str = '13.0
23.0
23
24,0
13A0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);