// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([A-Z]{2}-\d{2}-(\d|[A-Z]){2})|(\d{2}-(\d{2}-[A-Z]{2}|[A-Z]{2}-\d{2})))$").unwrap();
let string = "AA-00-00
00-00-AA
00-AA-00
AA-00-AA
AAA-00-AA
AA-AA-00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}