package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([A-Z]{2}-\d{2}-(\d{2}|[A-Z]{2}))|(\d{2}-(\d{2}-[A-Z]{2}|[A-Z]{2}-\d{2})))$`)
var str = `AA-00-00
00-00-AA
00-AA-00
AA-00-AA
AA-00-A2
AAA-00-AA
AA-AA-00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}