const regex = /^(\S+|\S+\s+\d+\s+\S+) (\S+ )?sshd\[\d+\]: Failed password for (invalid user |illegal user )?(\S*) from (\S+)( port \S+ \S+\s*)?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S+|\\S+\\s+\\d+\\s+\\S+) (\\S+ )?sshd\\[\\d+\\]: Failed password for (invalid user |illegal user )?(\\S*) from (\\S+)( port \\S+ \\S+\\s*)?', '')
const str = `May 23 16:57:33 nostalgia-for-infinity sshd[8541]: Failed password for invalid user root from 8.8.8.8 port 123 ssh2 from 127.0.0.1 port 50594 ssh2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}