$re = '/<Notes>(?:(?!<Notes>)[\s\S])*?sample(?:[\s\S\w]+)<\/Notes>(?:(?<![\s\S\w]<\/Notes>))*?/mU';
$str = 'TextBefore<Notes>this is sample notes</Notes>TextWiths1ample<Notes>this is sample notes</Notes>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);