# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([(\w|N°|#|.\s]+\d+)"
test_str = ("Colón N° 346 (Entre 21 de Mayo y Sotomayor)\n"
"Diego Portales Nº2291\n"
"Av. Pedro Aguirre Cerda N° 1010\n"
"Tarapaca N° 729\n"
"Local 3 A 1er. Piso, Centro de Convenciones Zofri\n"
"Av. Héroes de la Concepción Nº 2653 \n"
"Cerro Esmeralda 3130\n"
"Mall Calama, Balmaceda N° 3242 Local S-08\n"
"Av. Chorrillos # 1759 Local 1082 Exterior Jumbo\n"
"Av. Balmaceda N° 2355 Local BS - 121 / Subterráneo sector servicios\n"
"Av. Balmaceda N° 2337 - Local 2\n"
"Angamos N° 610 (Interior Universidad)\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.