#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((feature|bugfix|hotfix)\/([a-zA-Z]{2,6}-\d{1,6}|NO-?JIRA)\-[a-zA-Z0-9-_]{1,30}|release\/\d+\.\d+\.?\d*)$"
Local $sString = "release/0.8" & @CRLF & _
"release/58.11" & @CRLF & _
"release/58.15.45" & @CRLF & _
"feature/VECTWO-1234-Something-Here" & @CRLF & _
"" & @CRLF & _
"release/RC-0.8" & @CRLF & _
"release/58" & @CRLF & _
"feature/VECTWO-1234-Something-Really-Long-Too-Long-In-Fact"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")