const regex = /^((feature|bugfix|hotfix)\/([a-zA-Z]{2,6}-\d{1,6}|NO-?JIRA)\-[a-zA-Z0-9-_]{1,30}|release\/\d+\.\d+\.?\d*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((feature|bugfix|hotfix)\\\/([a-zA-Z]{2,6}-\\d{1,6}|NO-?JIRA)\\-[a-zA-Z0-9-_]{1,30}|release\\\/\\d+\\.\\d+\\.?\\d*)$', 'gm')
const str = `release/0.8
release/58.11
release/58.15.45
feature/VECTWO-1234-Something-Here
release/RC-0.8
release/58
feature/VECTWO-1234-Something-Really-Long-Too-Long-In-Fact`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}