using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\s+(?:misses|makes)\b.*$";
string input = @"D. Rodman makes 2-pt layup (assist by L. Longley)
M. Jordan misses 2-pt jump shot from 15 ft";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}