use strict;
my $str = 'D. Rodman makes 2-pt layup (assist by L. Longley)
M. Jordan misses 2-pt jump shot from 15 ft';
my $regex = qr/^(.*?)\s+(?:misses|makes)\b.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}