package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+?(380 |0)(6(7|8)|9(6|7|8)) \d{3} \d{2} \d{2}`)
var str = `068 987 65 43`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}