import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]{2,3})([\\s.-]?)([0-9]{3,4})([\\s.-]?)([0-9]{4})$";
final String string = "55 1234 5678\n"
+ "614 123 4567\n"
+ "1234568791\n"
+ "55 555 5555\n"
+ "32 1123 3212 9999\n"
+ "asdasdasda\n\n\n"
+ "// For Mexico check length\n"
+ "if(chosenRegex === phoneMx) {\n"
+ " const phoneMxLenght = $.trim(value.replace(/[\\s.-]?/g, '')).length;\n"
+ " if (phoneMxLenght !== 10) {\n"
+ " this.error = this.labels.errors.format;\n"
+ " return;\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}