#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<cometes>[\'\"])(.*?)(?P=cometes)$"
Local $sString = "' "pep = 12" as'" & @CRLF & _
"" & @CRLF & _
"' "pep = 12" '" & @CRLF & _
"" & @CRLF & _
"test "" 'pep "= 12' ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")