using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<cometes>[\'\""])(.*?)(?P=cometes)$";
string input = @"' ""pep = 12"" as'
' ""pep = 12"" '
test "" 'pep ""= 12' """;
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}