// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?P<cometes>[\'\"])(.*?)(?P=cometes)$"#).unwrap();
let string = "' \"pep = 12\" as'
' \"pep = 12\" '
test \"\" 'pep \"= 12' \"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}