# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z0-9_]*(?:[a-zA-Z][a-zA-Z0-9_]*){2,}\d{3}[a-zA-Z]{1,2}$"
test_str = ("6C1Q6K271BH\n"
" //это должно пройти проверку\n\n"
"038103469AD\n"
" // это не должно \n\n"
"038103469AE\n"
" // это не должно \n\n"
"03G103469H\n"
" // это не должно \n\n"
"4M5G6K272HE\n"
" //это должно пройти проверку\n\n"
"5M5G6K272H\n"
" //это должно пройти проверку")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.