re = /^[a-zA-Z0-9_]*(?:[a-zA-Z][a-zA-Z0-9_]*){2,}\d{3}[a-zA-Z]{1,2}$/m
str = '6C1Q6K271BH
//это должно пройти проверку
038103469AD
// это не должно
038103469AE
// это не должно
03G103469H
// это не должно
4M5G6K272HE
//это должно пройти проверку
5M5G6K272H
//это должно пройти проверку'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end