re = /\s+(\S+)$/m
str = 'Комплект мебели Фея Досуг 201 Алфавит зеленый 5693-3
Комплект мебели Ника Веселая азбука NKP1/5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end