// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<input\sclass="InputfieldFileSort")"#).unwrap();
let string = "<input class=\"InputfieldFileSort\" type=\"text\" name=\"sort_carousel_images_13cf00760bff00f05d6a3a3b2c40a1e7\" value=\"0\">";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}