import Foundation
let pattern = #"(<input\sclass="InputfieldFileSort")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<input class="InputfieldFileSort" type="text" name="sort_carousel_images_13cf00760bff00f05d6a3a3b2c40a1e7" value="0">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}