re = /\bR-?(?<Lower>\d{9})\b/m
str = 'ABCD/SESSION REMARKS/SESSION REMARKS_002FT2213700215_ /CODTYPTR/049 //R101841246/058 Session 220517080 REF: 02024741031486605002FT221
"R-101880298/GTB - GTB 981018802981 from GENERAL To GENERAL REF: 0000202582697981018802981 REF:205000000000760015362205171040" and "R101880298/GTB - GTB 981018802981 from GENERAL To GENERAL REF: 0000202582697981018802981 REF:205000000000760015362205171040'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end