// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bR-?(?<Lower>\d{9})\b").unwrap();
let string = "ABCD/SESSION REMARKS/SESSION REMARKS_002FT2213700215_ /CODTYPTR/049 //R101841246/058 Session 220517080 REF: 02024741031486605002FT221
\"R-101880298/GTB - GTB 981018802981 from GENERAL To GENERAL REF: 0000202582697981018802981 REF:205000000000760015362205171040\" and \"R101880298/GTB - GTB 981018802981 from GENERAL To GENERAL REF: 0000202582697981018802981 REF:205000000000760015362205171040";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}