#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^Traceback" & @CRLF & _
"[\s\S]+?" & @CRLF & _
"(?=^\[|\Z)"
Local $sString = "Started by upstream project "run_script" build number 435" & @CRLF & _
"originally caused by:" & @CRLF & _
" Started by user test" & @CRLF & _
"[Pipeline] {" & @CRLF & _
"[Pipeline] stage (Svnup)" & @CRLF & _
"Entering stage Svnup" & @CRLF & _
"+ python -m test.cli install 479CI9SOZ android://0.0.0.0:10000/479CI9SOZ /root/workspace/group/apk/com.data.app.apk - - false false" & @CRLF & _
"[03:21:33][DEBUG]<android> /root/env/common/test/test/core/android/adb/linux/adb -H 0.0.0.0 -P 10000 -s 479CI9SOZ wait-for-device" & @CRLF & _
"Traceback (most recent call last):" & @CRLF & _
" File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main" & @CRLF & _
" "__main__", fname, loader, pkg_name)" & @CRLF & _
" File "/usr/lib/python2.7/runpy.py", line 72, in _run_code" & @CRLF & _
" exec code in run_globals" & @CRLF & _
" File "/root/env/common/test/test/cli/parser.py", line 55, in main" & @CRLF & _
" run_script(args)" & @CRLF & _
" File "/root/env/common/test/test/core/helper.py", line 224, in wrapper" & @CRLF & _
" return f(pictarget, *args[1:], **opargs)" & @CRLF & _
" File "/root/env/common/test/test/core/main.py", line 408, in assert_exists" & @CRLF & _
" raise AssertionTimeout("%s does not exist in screen" % v)" & @CRLF & _
"AssertionTimeout: MoaPic(group_login.owl/tpl1487844291185.png) does not exist in screen" & @CRLF & _
"EndOfStream" & @CRLF & _
"[03:23:18][DEBUG]<android> /root/env/common/test/test/core/android/adb/linux/adb -H 0.0.0.0 -P 10000 -s 479CI9SOZ forward --remove tcp:12671" & @CRLF & _
"+ python -m test.cli run 479CI9SOZ android://0.0.0.0:10000/479CI9SOZ /root/workspace/group/util/scripts/group_login.owl " & @CRLF & _
"rpc_uri: http://0.0.0.0:12708/jsonrpc/0" & @CRLF & _
"rpc_uri: http://0.0.0.0:12708/jsonrpc/0" & @CRLF & _
"Traceback (most recent call last):" & @CRLF & _
" File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main" & @CRLF & _
" "__main__", fname, loader, pkg_name)" & @CRLF & _
" File "/usr/lib/python2.7/runpy.py", line 72, in _run_code" & @CRLF & _
" exec code in run_globals" & @CRLF & _
" File "/root/env/common/test/test/__main__.py", line 5, in <module>" & @CRLF & _
" main()" & @CRLF & _
" File "/root/env/common/test/test/cli/parser.py", line 55, in main" & @CRLF & _
" run_script(args)" & @CRLF & _
" File "/root/env/common/test/test/cli/runner.py", line 124, in run_script" & @CRLF & _
" exec_script(args.script, scope=globals(), root=True)" & @CRLF & _
" File "/root/env/common/test/test/cli/runner.py", line 186, in exec_script" & @CRLF & _
" exec(compile(code, scriptpath, 'exec')) in scope" & @CRLF & _
" File "/root/env/common/mator/mator/mator.py", line 520, in start" & @CRLF & _
" raise IOError("RPC server not started!")" & @CRLF & _
"IOError: RPC server not started!" & @CRLF & _
"[03:24:40][DEBUG]<android> /root/env/common/test/test/core/android/adb/linux/adb -H 0.0.0.0 -P 10000 -s 479CI9SOZ forward --remove tcp:12708" & @CRLF & _
"[03:26:41][DEBUG]<main> ->sift result: None" & @CRLF & _
"[03:26:41][DEBUG]<main> match result: None" & @CRLF & _
"Traceback (most recent call last):" & @CRLF & _
" File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main" & @CRLF & _
" "__main__", fname, loader, pkg_name)" & @CRLF & _
" File "/usr/lib/python2.7/runpy.py", line 72, in _run_code" & @CRLF & _
" exec code in run_globals" & @CRLF & _
" File "/root/env/common/test/test/core/main.py", line 195, in touch" & @CRLF & _
" pos = loop_find(v, timeout=timeout)" & @CRLF & _
" File "/root/env/common/test/test/core/utils/logwraper.py", line 70, in wrapper" & @CRLF & _
" res = f(*args, **kwargs)" & @CRLF & _
" File "/root/env/common/test/test/core/cv.py", line 83, in loop_find" & @CRLF & _
" raise NotFoundException('Picture %s not found in screen' % query)" & @CRLF & _
"test.core.error.NotFoundException: 'Picture MoaPic(group_login.owl/tpl1482311722698.png) not found in screen'" & @CRLF & _
"+ python -m test.cli stop_screen_record android://0.0.0.0:10000/479CI9SOZ 479CI9SOZ.mp4" & @CRLF & _
"ERROR: script returned exit code 1" & @CRLF & _
"Finished: FAILURE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")