package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/test\/[^\/]+\/contact\/[^\/]+$`)
var str = `/test/1234/contact/abcd
/test/abcd/1234/contact/abcd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}