#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.* (?!.* ))?a ?b ?c ?d ?e ?f ?g ?h ?i ?j ?k ?$"
Local $sString = "a bcdefghijk" & @CRLF & _
"ab cdefghijk" & @CRLF & _
"abc defghijk" & @CRLF & _
"abcd efghijk" & @CRLF & _
"abcde fghijk" & @CRLF & _
"abcdef ghijk" & @CRLF & _
"abcdefg hijk" & @CRLF & _
"abcdefgh ijk" & @CRLF & _
"abcdefghi jk" & @CRLF & _
"abcdefghij k" & @CRLF & _
"abcdefghijk " & @CRLF & _
"abcdefghijk" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")