using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]+(?:[[:punct:]][A-Z]+)*(?=\s+application)";
string input = @"Conversion routine for the NYC.GENX application. - should show 'NYC.GENX'
Conversion routine for the CAP-GENY application. - should show 'CAP-GENY'
Conversion routine for the NNUAT_CHECK application. - should show 'NNUAT_CHECK'
Created on 1/1/14 11:40 AM for RUN_SCRIPT application. - should show 'NNUAT_CHECK'
Event created on 2/2/14 12:29 PM for the STOP_SERVER application. - should show 'STOP_SERVER'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}