const regex = /[A-Z]+(?:[[:punct:]][A-Z]+)*(?=\s+application)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]+(?:[[:punct:]][A-Z]+)*(?=\\s+application)', 'g')
const str = `Conversion routine for the NYC.GENX application. - should show 'NYC.GENX'
Conversion routine for the CAP-GENY application. - should show 'CAP-GENY'
Conversion routine for the NNUAT_CHECK application. - should show 'NNUAT_CHECK'
Created on 1/1/14 11:40 AM for RUN_SCRIPT application. - should show 'NNUAT_CHECK'
Event created on 2/2/14 12:29 PM for the STOP_SERVER application. - should show 'STOP_SERVER'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}