import re
regex = re.compile(r"[A-Z]+(?:[[:punct:]][A-Z]+)*(?=\s+application)")
test_str = ("Conversion routine for the NYC.GENX application. - should show 'NYC.GENX'\n"
"Conversion routine for the CAP-GENY application. - should show 'CAP-GENY'\n"
"Conversion routine for the NNUAT_CHECK application. - should show 'NNUAT_CHECK'\n"
"Created on 1/1/14 11:40 AM for RUN_SCRIPT application. - should show 'NNUAT_CHECK'\n"
"Event created on 2/2/14 12:29 PM for the STOP_SERVER application. - should show 'STOP_SERVER'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")