package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\bhttps?://(\w+(?:[.-]\w+)*\.(?:ly|org|com|cc))\b`)
var str = `https://www.amazon.com/Technology-Ventures-Enterprise-Thomas-Byers/dp/0073523429
http://www.interactivedynamicvideo.com/
http://www.nytimes.com/2007/11/07/movies/07stein.html?_r=0
http://evonomics.com/advertising-cannot-maintain-internet-heres-solution/
HTTPS://github.com/keppel/pinn
Http://phys.org/news/2015-09-scale-solar-youve.html
https://iot.seeed.cc
http://www.bfilipek.com/2016/04/custom-deleters-for-c-smart-pointers.html
http://beta.crowdfireapp.com/?beta=agnipath
https://www.valid.ly?param
http://css-cursor.techstream.org`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}