package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\<\>\s+:\s+(?<field1>\d+)`)
var str = `msg: 2018-07-07 14:30:02.226 INFO 7 --- [nio-8080-exec-6] c.f.p.a.service.CGEventRetimeService : <> : 12006`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}