#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[^DFIOQUWZ]\d[ABCEGHJ-NPRSTV-Z][\s|\-]?\d[ABCEGHJ-NPRSTV-Z]\d"
Local $sString = "h1bl3c" & @CRLF & _
"H1V 2M2" & @CRLF & _
"h1bl3c" & @CRLF & _
"m3S34s" & @CRLF & _
"m4e3s5" & @CRLF & _
"H1VeM2" & @CRLF & _
"M4M-2N2" & @CRLF & _
"m4m 2n2" & @CRLF & _
"H0H 0H0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")