package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)if \((.*?)[=](.*?)\)`)
var str = `if (ddd = dd)
if (eee == ee)
if (fff === fff)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}