use strict;
my $str = 'MS-05B
05B-MS
ザク MS 05B
(旧ザク)MS-05B ザクI
MS: 05B
;MS;
"MS"
\'MS\'
MS.MS,MS
[MS]
{MS}
MS -- 改行は境界扱い
(MS) -- 全角記号は境界扱い
{MS}
-- 数値は境界扱いされない
001MS999
-- 非アルファベット文字が境界扱いされる(PCRE/JS/Python/Golang)
ザクMSザク
量産MS量産';
my $regex = qr/\bMS\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}